Mail server performance
Incident Report for Walrus Computers
Resolved
This incident has been resolved.

If you continue to experience issues, please log a ticket through walruscomputers.com
Posted Nov 06, 2024 - 12:30 GMT
Investigating
We are currently investigating an issue impacting Email.

This can present as slow loading or login issues for outlook and for webmail users.

We will provide an update once we have additional information.
Posted Nov 06, 2024 - 12:11 GMT
This incident affected: eMail.