Mail server performance
Incident Report for Walrus Computers
Resolved
The intermittent issues have been resolved. If you are still experiencing issues please log a ticket through walruscomputers.com
Posted Nov 18, 2024 - 20:12 GMT
Update
Intermittent issues remain, we are continuing to work on the issue.
Posted Nov 18, 2024 - 17:56 GMT
Monitoring
The server connections are currently returning to expected levels for both mail clients and webmail access.

We are monitoring this and will provide updates.
Posted Nov 18, 2024 - 15:27 GMT
Investigating
We are currently experiencing an intermittent issue with the mail service.
This may appear as slowness or a pop up box.
We are currently investigating this.
Posted Nov 18, 2024 - 12:59 GMT
This incident affected: eMail.